Installing External Packages

Before setting up the IceCube software environment, you need to verify or install the following applications.

Python 2.x
This comes installed by default for Linux and Ma OSX platoforms. Users of Cygwin will need to install it by hand.

Your $PATH must be able to find the python binary.

Java
The Icecube project has decided that the only acceptable version of Java to use will be the SDK v 1.4.2_04. If your system uses some other version, either remove it or move it to a non-standard location on your system.

All standards of DAQ environment installers will attempt to install the right version. Cygwin and Mac OSX users will have to install this by hand.

Your $JAVA_HOME must then be set correctly.
Your $PATH must also include $JAVA_HOME/bin.

JBoss
All standards of DAQ environment installers will attempt to install the right version of this. Since this is distributed via gzipped tarball, all platforms should be able to handle the installation.

Next, go to: Obtaining an Account on glacier.lbl.gov


Back to: Main Page


Generated on Wed Sep 29 06:31:02 2004 by doxygen version 1.3.4